Microsoft Edge browser fails to launch and stay up

posted Jul 11, 2017, 2:05 PM by Andrew Chadick   [ updated Jul 18, 2017, 6:50 AM ]
After a recent update, Edge is crashing.

Normally running the executable from PowerShell:   explorer.exe microsoft-edge:http://www.microsoft.com  
will launch edge and go to that microsoft.com page.

But it doesn't.  The browser opens briefly then crashes and closes.  No apparent rhyme or reason to it.  It also has some other odd behaviors when you force it.

There are some actions that will sometimes work with Edge, like killing it's cache folders:
Cache location: C:\users\%username%\appdata\local\packages\microsoft.microsoftedge_8wekyb3d8bbwe 
And reinstalling it with this PowerShell script:
Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 

But for me, on 3 of my machines, the above isn't working.  Edge repopulates that folder location with new contents, and the browser still goes down.

So here is what I know, and have observed:

Open PowerShell and then copy/paste:      explorer.exe microsoft-edge://        then press enter.  

Edge will open.  But it loads as a blank window...and further, it's pretty useless in this state. 
You can't surf to any sites.  You can however edit settings, clear history, and do those kind of operations.  
(edit 7/18 - I may have been mistaken about its state at this point, if you click on the new tab while this blank window is open, a new tab may open to the home page and function within the home screen, but, will still display the same issues as shown below).

It's truly bizarre, but I did force it to launch.    

Now, let's dive deeper in to the weirdness that is broken Edge... Keep this same blank window open.  Now, click on Cortana, and search for/type "Edge".  Then launch the Edge Browser from the search selection at the top.  If that blank version of Edge is open still, then the Edge browser will open and bring up it's home page! (again, only if you have that previous window open in the background).  So, THE catch?  It won't go anywhere but the home page!  

You can still click around on that page, anywhere on the home page, scroll down, pull lots of new content, and it will show and allow you to interact, Click Politics, US, World, etc.. it will all work.., but try and open a new tab, or redirect the current tab to a new website? Nothing! 

You just get a Progress swirl in the upper left corner on the tab (see below).   


This happening on Windows 10 Enterprise x64, version 1703, build 15063.413. 
 - Just updated to build 15063.483 - same issue.

Not going to delete my user's profiles and rebuild them if I don't have to, that would be a last resort.  We have many other browser options that still work correctly.

Update 7/18 - while playing with various aspects of Edge, because I can't leave an open problem alone,... I ran this command from PowerShell as admin,  explorer.exe microsoft-edge://  once the browser window opened, I installed an extension in to the window using the Microsoft store.  The extension installed, and within that window, which normally stays blank, the home page loaded!  Now, it has the same problems as shown above, where it won't go anywhere but the home page, but it does show that the browser can launch and be functional to a point.  Still working on this. 

Comments