Is your Android phone compatible with the latest in Smart Watches? Find out.

Post date: Jun 27, 2014 1:15:35 PM

Android Wear is designed to work with Android phones running 4.3 or higher. Not sure what version of Android you have? Visit http://www.android.com/wear/check/ on your phone to see if it’s compatible with Android Wear.